
Behind the Digital Screen 
Assignment 1: Graphics 
 
Deadline: Monday, 2/1, 3pm (one hour before class begins) 
 
 

KEEP CALM AND CARRY ON 
 
The assignment is written such that a person who has never “touched” a computer graphic can 
understand and complete the steps in full. There are many instructions in this assignment, 
however most correspond to a very quick action, so don’t be alarmed by the number of steps! 

 
Objectives: 

 Become familiar with different types of web graphics. 
 Understand the difference between raster and vector formats. 
 Explore the relationship between a format and what it can represent.  

(Using examples: alpha channel, editing raw files, and color modes).   
 
 
What to Turn in: 
 

During the assignment you will need to save several files that you will later submit when turning 
in your work. The deliverable files below will make sense as you go through the assignment. 

 
Labels refer to the steps in this document. You will obtain the text response for A42, for 
example, in step 42 of Section A, and so on. 

 
Please name these files with the numbers on this list in the title to help us easily give you credit!  
(e.g., 1.png 2.svg 3.svg 4.png 5.png 6.png 7.png 8.png 9.svg 10.docx) 

 
 1. PNG file with transparency layer (step A37) 
 2. Raster image you found on the Internet (step A41) 
 3. PNG composited image (step A58) 
 4. SVG file containing rectangles, circle/oval, word, etc. (step B29) 
 5. SVG file that used to contain a single triangle (after text editor manipulations) (step B56) 
 6. color PNG (step C9) 
 7. grayscale PNG (step C11) 
 8. duotone (1-bit) PNG (step C16) 
 9. five-color PNG (step C20) 
 10. custom palette PNG (step C23) 
 11. your SVG graphic file (from part D) 
 12. your lab write-up (a Microsoft Word file) 

 
Upload these files to the class Canvas site with a timestamp before the deadline. 
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Part Zero: Before you begin 
 
What You’ll Need to Complete This Assignment: 

 A raster image editor: GIMP (from the class software page: http://313.niftyc.org/software ) 
 A vector image editor: Inkscape (from the class software page: http://313.niftyc.org/software ) 
 Internet access, a web browser, and a basic text editor such as one built-in to your operating 

system (e.g. Notepad, TextEdit). 
 A place to save your work (a USB drive, Google Drive, your computer’s hard drive, etc.) 

 
Alternative Software: 

If you want to, you can use this alternative software. However this lab assignment will only 
contain instructions for the preferred software listed above. 
 
 Instead of GIMP, you can use Adobe Photoshop 
 Instead of Inkscape, you can use Adobe Illustrator 

	
	
	
Part	A.	Bitmaps	and	transparency	

 
OVERVIEW: In this section you will create a raster image with a transparency (alpha) layer, composite 
this image on a second image, duplicate the result, and manipulate its scale using the image editing 
software GIMP. 
 

1. Pick an image to start with. Open a web browser and navigate to the following page: 
http://commons.wikimedia.org/wiki/Category:Images_uploaded_at_reduced_resolution  
This is a Wikimedia Commons page containing raster images that were uploaded at reduced 
resolution. 

 
2. Locate the sunflower on this page, it is labeled ‘200px-Fleur-de-Tournes… 74,835 bytes’. 

Instead of visually searching this long page for a sunflower, use your web browser’s built-in text 

find function. Activate the text find tool by pressing CTRL + F (on a PC) or Command (⌘) + F 

(on a Mac) at the same time. This text find tool is also accessible through the menus at the top of 
your browser (e.g. in Firefox you would go to Edit > Find). Enter “fleu” in the find box and press 
ENTER. This will take you to the proper image on the page. 

 
3. Once you locate this sunflower image on the page, click on the image. The image is linked to 

another page where you can download a PNG image file named ‘200px-Fleur-de-
Tournesol.PNG’.  

 
4. Download the file 200px-Fleur-de-Tournesol.PNG to your local computer. Right click (or CTRL 

+ right click) on the image and then choose “save image as…” and save the file to your local 
machine. Be sure to note where you save this file as you will be using it in the next steps. 

 
5. On your computer, open GIMP, our image editing software. (GIMP is a free alternative to Adobe 

Photoshop containing many of Photoshop’s most commonly used functions.)  
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EXTRA HELP 
 
By default, GIMP launches three separate windows: Image window, Toolbox window, & Layers 
window. In order to do anything in a different window (e.g. switch from using the Image window to 
selecting a new cursor tool in the Toolbox window, you must first select (click) on that window to 
activate it and then click again for your selection. This is only the case when you are moving from 
Image window to Toolbox to Layers and in between. So click to activate a GIMP window, then click 
again to make changes. This will make more sense as you use the program.  

 
6. In GIMP, open the file by selecting File > Open and browse to the 200px-Fleur-de-

Tournesol.PNG file stored on your local machine, the one you saved in the previous steps. 
(Alternatively, to open files in GIMP and most other applications you can use the file open 

shortcut CTRL + O (on a PC) or Command (⌘) + O (on a Mac). 

 
7. Before the sunflower image contained in file 200px-Fleur-de-Tournesol.PNG opens in GIMP, a 

dialog box will prompt you to first assign a color profile to this image. The default color profile 
should be “RGB workspace (sRGB …)”. If this appears in the Assign dropdown click on the 
Assign button. If not, select this ‘RGB workspace…’ color profile from the drop down list and 
then select the Assign button. If no color profile dialog appears just proceed to the next step 
anyways. 

 

 
 

8. When the PNG bitmap image file opens in the GIMP Image window, you should see the image 
containing a yellow sunflower with green background appear in a new Gimp Image window. 

 
9. In GIMP, perform the following edits to this PNG image file: From the drop down menus at the 

top of the GIMP Image window, select Image > Scale Image. A Scale Image dialog will appear 
revealing the Image Size in pixels. Notice the Width and Height are currently 200 pixels each. In 
the Scale Image dialog select Cancel without changing anything. (We just want to see how big 
the image is in pixels.) 

 
10. Now view the 200x200 pixel image at different zoom levels in GIMP. You can do this a number 

of ways. One is to press the + (‘plus’) and – (‘minus) keys. On some versions of GIMP you can 
also click on the up/down button located next to the zoom % level at the bottom of the GIMP 
Image window. You can also type a numeric value in the zoom % box next to the up/down button 
and press ENTER. Yet another method is to select the View drop down menu from the top of the 
GIMP Image window and select Zoom (x%) >  then choose a zoom level. Still yet another 
method…(Get the idea? There are many ways to do the same thing. TMTOWTDI.) is to navigate 
the cursor to the Toolbox window and select the magnifying glass icon, and then with magnifying 
glass cursor left click (zoom in) or CTRL + left click (zoom out) on the image to alter the zoom.  
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11. Zoom to 500% using the zoom % box at the bottom of the screen: enter the value 500% and 
press ENTER. You should be able to see individual pixels in the sunflower bitmap image. Using 
your mouse scroll wheel function or the scroll buttons on the right and bottom of the GIMP 
Image window, navigate and pan around the image while zoomed in 500%.  
 

12. Do the same for 1000%, 2000%, and higher %’s as you increasingly notice the pixels and 
underlying raster grid contained in the PNG file. Eventually all you should see on the screen are 
undecipherable squares of color.  There are 200 of these squares in the vertical dimension and 
200 in the horizontal dimension. In this bitmap example, each pixel corresponds to a unique (x, y) 
numerical address in the 200 by 200 pixel grid of the image file, and each of these pixels exhibits 
a single color value when displayed using the RGB workspace in GIMP. 

  
13. Play around with various zoom settings until it is clear to you why this bitmap image has a 

resolution of 200 x 200 pixels and how these individual units combine to form the overall image. 
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14. Now select from the drop down menus at the top of the Image window: View > Zoom (x%) > Fit 
Image in GIMP Image Window. This will re-zoom the image so it fills your GIMP Image 
window and is easiest to work with. Previously when you were zooming in and out in GIMP you 
were simply commanding the software to render the image at a different pixel density on your 
computer’s screen, but were NOT changing the actual stored resolution in your PNG image file 
(the pixels in the bitmap remained 200x200, you just zoomed in on your screen). 

 
15. In GIMP, using the drop down menus at the top of the Image window, return to the Image > 

Scale Image… dialog. 
 

16. Using the Scale Image dialog you are going to “scale up” this sunflower image. You’ll add 
more samples (or resolution) to an image that has already been sampled. Enter the numerical 
values 2000 x 2000 (replacing 200 x 200) in the Width and Height boxes and then select the Scale 
button. 

 
17. Notice: You have now ‘scaled up’ this bitmap image by introducing new pixels (this is very 

bad!) that were not previously stored in the image. For each of the previous pixels in the 200 x 
200 bitmap image, you now have 100 new pixels corresponding to each original pixel. You have 
effectively ‘exploded’ each old pixel by coping it 99 times. Notice how the result is nothing like a 
crisp and clear 2000 x 2000 photograph that started at a high resolution.  

 
18. With this scaled up image, zoom in to 1000% and then scroll to the area of the image where the 

exterior of the yellow sunflower meets the green background. You should be able to see the 10 x 
10 blocks of pixels, most visible near the boundary of the yellow and green touching regions. For 
every 1 original pixel you added 99 more! Remember this is very bad.  
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19. Notice: While this scaled up image is technically 10 times larger in both spatial (height/width) 
dimensions, the new pixels are just copies (‘clumps’) of pixels resulting in a blurry yet 
technically ‘high resolution’ (2000 x 2000) image. 

 
TIP: Changing a relatively low resolution raster (bitmap) image to a higher resolution image is almost 
always a bad idea and should be avoided. 
 

20. An advisory: In the previous steps you changed a ‘low resolution’ bitmap/raster image to a ‘high 
resolution’ image simply by copying pixels. Notice the results of trying to add pixels to a 
bitmap/raster image: the computer is happy to let you do this, it will never stop you, however the 
resulting “larger” image looks much worse than the smaller original. In general, you should only 
decrease the resolution of a bitmap/raster image never increase it (never add new copies of 
existing pixels). You could for example go from a 200x200 image to 100x100 to reduce the size 
of the image without any additional loss in image quality. Under normal circumstances for 
displaying bitmap/raster images you should never increase the resolution of a bitmap (raster) 
image. Please re-read this last underlined statement, again and again, and make the following 
pledge: “I will never increase the resolution of a bitmap/raster image.” Write it down, Tweet it, 
Blog it, Tumblr it, Snapchat it, make it your Facebook status, whatever it takes to remember this. 
There are not many unforgivable things when working in digital media, however ‘scaling up’ a 
raster image is one.  

 
21. Now we want to revert to the original, unaltered, 200x200 sunflower image. You can simply use 

the undo function in GIMP by selecting from the top drop down menus in the Image window: 
‘Edit > Undo’ or use keyboard shortcut CRTL + Z. Alternatively, you could also close the altered 
2000x2000 image (do not save when prompted) and reopen the original 200x200 PNG bitmap 
file. If you accidentally resave the 2000x2000 image simply re-download it from the Wikimedia 
Commons. 

 
22. With the original 200x200 sunflower PNG bitmap file opened in GIMP, using your mouse cursor, 

select from the drop down menus at the top of the Image Window: View > Zoom (x%) > Fit 
Image in Window. You can resize this Image window by dragging the bottom right corner, and 
then continue fitting the image to its size as helpful using the Fit Image in Window option. 

 
23. Add a transparency (alpha) layer to your PNG image: From the drop down menu at the top 

choose Layer > Transparency > Add Alpha Channel. You will not see any visible changes at this 
time. 

 
24. From the Toolbox window, using your mouse cursor choose the Fuzzy Select Tool to change 

your cursor’s functionality.1 This tool looks like a magic wand. It should be in the top row of the 
Toolbox near the middle of this row. The Fuzzy Select Tool in GIMP (and many other 
applications) is a quick and dirty tool for selecting contiguous groups of pixels based on their 
relative intensity/color values to one another in the selected region. You might use it if you are in 
a hurry or have very clear and distinct intensity/color boundaries in your image. For the sunflower 
image it works pretty well for what we want to do. 

 

																																																								
1	GIMP’s	“Fuzzy	Select”	tool	is	called	the	“Magic	Wand”	in	Adobe	Photoshop.	
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25. Note: Once you choose the Fuzzy Select Tool for your GIMP cursor, hover the cursor over the 
sunflower image. Observe how the mouse cursor now looks like the Fuzzy Select (magic 
wand) Tool icon. This is how cursor selection works in GIMP: your cursor will reflect the current 
Tool you have selected previously in the Toolbox.  

 
26. With the Fuzzy Select Tool active, in the bottom half of the Toolbox window you can find a few 

settings that affect it (Antialiasing, Feather edges, etc.). 
 

27. Enter the following settings for the Fuzzy Select Tool: check Antialiasing and uncheck Feather 
edges, check Select transparent areas and check Sample merged. Ether by using the slider or 
entering a numerical value, set the Threshold value to 115.0. The Select by drop down menu 
should be set to Composite. 

 
28. On your sunflower image in the Image window, using the Fuzzy Select Tool, left-click on an 

outer region near the image’s edge, somewhere not touching the yellow (the flower portion). For 
example left-click in the top-left corner of the image.  

 
29. You have now selected a contiguous region of bitmap pixels based on color, using a Threshold of 

115. Notice the blinking dashed line indicating your area of selection. Finding the proper 
Threshold is key to using this tool. To notice how Threshold works for this and other tools, raise 
and lower this Threshold value and select various regions of the sunflower image with your 
mouse curse at different Threshold values. Notice how higher Threshold values correspond to 
more pixels selected in contiguous regions and vice versa.  

 
30. Deselect all pixels by going to the top drop down menu at the top of the Image window: Select > 

None. 
 

31. With the Fuzzy Select Tool active, reset its parameters to those specified previously in step 27 
(including setting Threshold at 115.0) and once again select an outer region of the image, 
somewhere in the green/black area and NOT on the yellow part of the sunflower. 

 
32. With this background green/black portion selected (indicated by blinking dashed line), in the drop 

down menus at the top of the Image window: choose Edit > Clear. 
 

33. All of the green/black background should disappear (or nearly all, depending on where you 
clicked the Fuzzy Select Tool). You have just deleted the intensity/color information for these 
pixels and as a result they are now transparent in GIMP as indicated by the white/gray checkered 



Part A 

pattern. Anytime you see this white/gray pattern it signifies that these pixels are empty and thus 
transparent. 

 
34. Using drop down menu at top choose Select > None. 

 
35. Depending on where in the green/black region you clicked using the Fuzzy Select Tool, you may 

have a few remaining non-flower pixels in your image. If so, from the Toolbox window change 
your mouse cursor to the Erase Tool. It looks like a pink eraser and should be in the fourth row 
near the middle, directly down a few rows from the Fuzzy Select Tool. Notice that once you 
select the Erase Tool the parameters in your Toolbox change. You can now set parameters for this 
Erase Tool. Changing the Scale alters the size of your eraser. Using the Erase Tool remove any 
green/black pixels that were not deleted. You can increase your precision by both zooming in 
and increasing/decreasing the size of your Erase Tool cursor. 

 

 

 
 

36. Get ready: Once you have a yellow sunflower with a transparent (white/gray checkered) 
background, you will now save this image (to be used later) in a way that preserves this 
transparency. Some raster/bitmap file formats do not allow transparency layers and assign 
any transparent regions to white or some other color when they are saved (such as jpeg files). 
However PNG files allow for transparency (or alpha) channels.  
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37. Save the new PNG file with this transparency layer: File > Export As... Rename the file and 
select place to save the image. (Be sure you can find this location again!) From the Select File 
Type menu in the Export As…dialog, select the following option: File Type: PNG Image / 
Extension: png.  

 
IMPORTANT: This .png file is the first file to be turned in for this assignment. Save it 
in the folder where you will keep all of the files (e.g., on your USB drive) that you will 
turn in later. Please put a “1” somewhere in the filename (e.g., sandvig-1.png). 

 
38. A Save PNG dialog will appear, you can usually accept the defaults which should be the 

following (if they are not change them): 4 boxes checked: Save gamma, Save resolution, Save 
creation time, Save color values from transparent pixels (this fourth one is most important for this 
exercise, it must be checked to preserve an transparency/alpha layer in your PNG file). Choose 
Save. 

 
39. Close the sunflower image: drop down menu at top choose File > Close View.  

 
40. Now open your newer PNG file with its transparency layer using several applications on your 

computer. Try Web browsers, photo/picture viewers (PC), Finder & Preview (Mac), etc. With this 
PNG file opened in your chosen web browser, zoom in as far as your browser allows. Notice how 
“pixelated” the image appears when viewed at increasingly larger screen resolutions. Many 
applications insert white for the transparent pixels, most web browsers do this. Each application 
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handles how transparent pixels are displayed, and some of them may display it differently -- using 
the white/gray checkered pattern, white, black, etc. 

 
41. Using a web browser, find and download a raster/bitmap image (class appropriate: no 

pornography, violent/vulgar content, etc.). This can be a .jpg, .png, .tif or others as long as it is a 
raster/bitmap file and as long as it is at least 400 pixels in each direction (height/width), so 
minimum size 400x400. There are millions (billions? trillions?) of digital images accessible 
online, just pick one that you want to work with and save it to your local computer. Based on the 
number of images on the internet, no two students’ images should be the same (do not use the 
same image as any of your classmates).  

 
IMPORTANT: The URL where you found your image is the first written answer in 
your lab report. You probably want to paste it into your lab report now.  The original 
bitmap image is the second file to be turned in for the assignment. Save a copy of the 
image to the folder where you will keep your images to turn in, and please include a “2” 
in the filename. 

 
42. Open this raster/bitmap image in GIMP. (Kanye is our choice, yours should be different.) 

 

 
 
 

43. Also open the modified sunflower image with transparency layer that you created in the 
previous section. You will see two Image windows for these two images in GIMP. Notice how 
each Image window has its own drop down menus at the top (e.g. File, Edit, …), yet there 
remains only a single Toolbox window and Layers window. These Layers window correspond to 
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whichever Image window you last opened, clicked on, or altered and the Toolbox always 
corresponds to your current mouse cursor. 

 
44. In the modified sunflower image, from drop-down menus at top of the Image window, choose 

Select > All. This selects all pixels including the transparent (empty) ones. 
 

45. Copy the entire sunflower image: choose Edit > Copy. 
 

46. With the sunflower image on your computer’s clipboard, click on the other Image window in 
GIMP, the one displaying the image you chose yourself and downloaded from the internet. 

 
47. Paste the sunflower image into a new layer in this image. From Image window of your chosen 

image: choose Edit > Paste as > New Layer. 
 

 
 

48. Notice: You should now see your sunflower image (with no background) appear somewhere ‘on 
top’ of the internet image you chose. You have just composited two raster (bitmap) images. 

 
49. Also observe that a new layer now appears in the GIMP Layers window above your background 

layer.  It should be above your background image on this list of layers. This new layer contains 
only the sunflower pixels and has a transparent background. It must be positioned above (on top) 
of your downloaded background image in this Layers window as GIMP ‘projects’ each layer in 
order starting from the top and moving to the bottom of this layers list. 

 
50. Make sure in the Layers window you have selected (highlighted) the sunflower layer, it should 

be highlighted in blue. Whenever you have more than one layer you must select the appropriate 
layer that you want to work with by clicking on it in the Layers window before you can alter its 
contents.  

 
51. In the cursor Toolbox, click the Move Tool, it looks like four arrows pointing in different 

directions, should be in the second row. 
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52. Using the Move Tool, left-click and hold on the sunflower image and drag it to your desired 
location within your larger base image. 

 
53. Click the Scale Tool from the Toolbox, located in the third row, icon is two blue squares one 

scaling to the size of the other. 
 

 

 
54. With the sunflower layer selected in the GIMP Layers window and the Scale Tool for your 

cursor, scale the sunflower up or down by left clicking and holding on the sunflower. (Despite 
the previous stated rule of NEVER scaling up a bitmap image and your previous pledge never to 
do so (!) it is okay for learning purposes in this exercise, after all there are exceptions to every 
rule.) Notice what happens when you hold CTRL while clicking and dragging to change the 
scale—the aspect ratio remains the same preventing you from skewing your layer out of its 
original proportions when scaling it. Also when you initiate the Scale Tool a Scale dialog appears 
allow you to alternatively numerically scale the layer to a specified pixel size, height/width. 

 
55. In addition to scaling this layer up or down, you can copy and paste this layer again and again in 

the same image. Or alternatively, once you have scaled the sunflower as you would like, you can 
Duplicate this layer in GIMP to save time. To duplicate a layer highlight this layer and choose 
Layer > Duplicate Layer. 

 
56. Copy/paste or duplicate the sunflower layer at least two more times, for a minimum of three 

sunflowers appearing on top of your chosen internet image. 
 

57. You should now have at least three sunflowers appearing on your chosen image. Alter the 
position and size of these. You can create as many sunflower layers as your heart desires, with 
different scales and aspect ratios, just make sure the underlying background image is not 
completely covered so that it is recognizable from your original source image. 
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58. Save the modified image containing your internet image and sunflower layer(s) as a new PNG 
file to your local computer. File > Export As… > (use previous PNG saving instructions). 

 
IMPORTANT: This is the third image you need to turn in to complete this 
assignment. Please include a “3” in the filename. 

 
59. Double-check: You should have three files from the previous steps as you will be turning these 

in. They include: 1) PNG modified sunflower image containing transparent background, 2) Your 
original chosen image you downloaded from the internet in its unaltered form, 3) The altered 
internet image containing at least three sunflowers. You should also have completed the first 
question in your lab report (the URL for the image you found.) 

 
 
You’re done with part A!
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Part B. Vector graphics 
 
OVERVIEW: In the previous section you were working exclusively with bitmaps/raster files (PNG, 
JPEG, etc.). In this section, B. Vector graphics, you will be working with an entirely different type of 
graphic file, a vector-based file. While bitmaps and vector images may sometimes appear similar when 
displayed, their underlying structure and corresponding strengths and weaknesses are very different. In 
this section you will create a vector graphic and manipulate it using the application Inkscape (as well as 
other methods). 
 

1. If you’ve never used Inkscape before (which is likely), first go through the Inkscape Basic 
tutorial in full. The tutorial is accessed within the application itself, by first launching Inkscape 
and opening the tutorial using the menus at the top of the screen: Help > Tutorials >  Inkscape: 
Basic.  
 

2. Open the application Inkscape. (If the Inkscape Basic tutorial file is still open, close it now.) 
 

3. Once the Inkscape application is open, resize the window as necessary by left clicking and 
dragging the bottom right corner. 

 
4. Change the document page properties by choosing File > Document Properties, on the Page tab 

change the Width and Height so both are 400.00 px. You can just type these values in to the 
Width/Height boxes. Close the Document Properties dialog. 

 
5. Double-check: You should see a square, outlined box in the middle of the Inkscape drawing 

window. You will create a graphic inside this bounding box. 
 

6. Use your mouse cursor to click the Create Rectangles and Squares tool (a blue/white square 
icon) from the Toolbox on the left of the Inkscape application window. Notice a small square 
now appears attached to your cursor, signaling which mouse cursor Tool is currently active. 

 
7. Draw three rectangular non-touching shapes within the bounding box using this Create 

Rectangles and Squares tool. 
 

8. Next, from the Toolbox click the Create Circles tool with your cursor, this is the pink circle.  
 

9. Inside one of your three rectangles draw a circular or oval shape. 
 

10. From the Toolbox click the Create Stars and Polygons tool. 
 

11. To set this Create stars and polygon tool to create a three sided shape, first at the top of the screen 
be sure the left yellow polygon is selected. Then to its right set the number of corners to 3.  

 
12. Inside a different one of your three rectangles (one of the two without the circle/oval) draw a 

triangle. 
 

13. For the third rectangle you will be creating text inside this box rather than a geometric shape. To 
do so first click the Create and Edit Text Objects tool from the toolbox on the left. This is the 
icon with a black A. 
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14. With the Create and Edit Text Objects tool active, left-click inside your only remaining empty 
rectangle. You should see a blinking cursor appear where you clicked. 

 
15. Type a word. (Make sure it’s a word you would say in front of your grandmother. Creators of 

any highly offensive words in this step or any other may be required to give a presentation to their 
lab section on the etymology and merits of their word.) 

 
16. You can change the font and size of the text tool’s output by adjusting these parameters in the 

drop down menus at the top of the Inkscape screen when this tool or any text is currently selected. 
Change the font and size so it is legible and fits inside your third empty rectangle.  

 
17. From the Toolbox on the left, click the black arrow (the Select and Transform Objects tool) at 

the top of the Toolbox. This allows you to select graphic elements and manipulate them in 
various ways.  
 

18. Use the Select and transform objects (arrow) tool to move the text so that it is inside the box. 
As needed, use this tool to ensure your circle/oval and triangle are also inside their respective 
rectangles. Change the size of any of your shapes or the text by choosing the Select and 
Transform Objects tool from the Toolbox and then clicking and dragging one of the black arrows 
that appears outlining the selected object. 

 
19. Once you are happy with each shape’s relative size, you will now alter the Fill and Stroke 

properties of your rectangles, circle/oval, and triangle, and change the color of your word. From 
the drop down menus at the top, open the Fill and Stroke parameters dialog by clicking Object >  
Fill and Stroke. 

  
20. With the Select and transform objects tool (arrow) selected, left click on one of your rectangles. 

You will notice the black arrows extending outward from this rectangle, indicating that it is 
currently selected.  

 
21. Notice: With this rectangle selected, in the Fill and Stroke parameters dialog, under the Fill tab 

you should see five sub-tabs: RGB, HSL, CMYK, Wheel, CMS. These sub-tabs allow you to 
alter the controls of the selected object using various color modes. 

 
22. You will now toggle between these sub-tab color modes and alter the background of your three 

rectangles, circle/oval, triangle, and word.  
 

23. With one of our objects/shapes highlighted, in the Fill and Stroke dialog select the Fill tab at the 
op left. Select the sub-tab RGB. Using the RGB channel controls change the color of the fill of 
your selected shapes. You can do this by manually entering a number between 0-255 in the four 
sections labeled R (red), G (green), B (blue), and A (alpha or transparency). Notice what happens 
to your shape as you alter these four numbers. As you might expect, setting R to 255, G to 0, and 
B to 0, produces a pure red color. In addition to typing in numeric values, you can also left click 
and drag side to side within the respective color gradients for RGBA. 

 
24. Next, select the HSL sub-tab. The RGBA option corresponds to red, green, blue, and 

alpha/transparency parameters. HSL stands for Hue, Saturation, and Luminosity. Use the controls 
in the HSL sub-tab to alter the hue, saturation, and luminosity of your selected object.  
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25. Next, select the CMYK sub-tab. CMYK is more similar to RGB, with C (cyan), M (magenta), Y 
(yellow) color controls, but also with the addition of K (black) control as well as alpha control. 
Change the color of your selected object using the CMYK sub-tab. 

 
26. Next, select the Wheel sub-tab. The Wheel color changing tool has three main controls. The first 

is the color to which the line extending out from one of the triangle’s vertices is touching. This 
setting determines the hue. Left click on the color spectrum ring to change the hue. Next you 
should see a small white or black circle inside the triangle. Click on this circle and drag it 
around within the triangle. Notice how the color changes in intensity and saturation. Finally, 
there is a basic alpha control at the bottom of Wheel labeled “A.”  

 
27. In this same Fill and Stroke dialog, you will also notice two additional tabs at the top (in addition 

to Fill): they are Stroke paint and Stroke style. Stroke refers to the outline/border of your shape. 
Change the Stroke paint parameters for your rectangles, circle/oval, and triangle to alter the 
stroke colors for these shapes. Change the Stroke style of these shapes as well. 

 
28. Notice that each time you must use the Select and transform objects (arrow) tool to indicate 

which item to change via the Fill and Stroke parameters dialog. You can also hold down the shift 
key to select multiple objects, and then change the Fill and Stroke of these items at the same 
time. 

 

 
 
 

29. Save your vector-based creation as an SVG (Scalable Vector Graphics) file. Choose File > Save 
As…. The Select file to save to dialog will appear. From the drop down on the bottom right 
corner, make sure Inkscape SVG (*.svg) is selected. Name and save the file to your local 



Part B 

machine. You will need this file later. 
 

IMPORTANT: This is the fourth file you will turn in.  Save a copy of it now. Please use a 
“4” in the filename. 

 
30. In Inkscape you will now create a new file. Close the SVG file you created in the previous step 

and Choose File > New > Default.  
 
31. In this new Inkscape file, draw a single triangle of any size. Alter its size as you wish, just as 

long as it remains inside the bounding box. Using the Fill and Stroke dialog alter these color and 
line properties as you wish.  

 
32. Save this single triangle as a new SVG file—however this time save it as a Plain SVG rather 

than an Inkscape SVG (this will remove a lot of lines of code from the file). Choose File > Save 
As… then in the bottom right corner select Plain SVG (*.svg) as the file type. 

 
 

 
 

33. Close Inkscape and ignore the message about saving a file “that may cause data loss”.  
 

34. You will now open and view both SVG files with a web browser. Open a web browser and in 
this application open your first SVG file, the one with multiple rectangles. (e.g. with Chrome you 
can drag the file into the browser window.) 
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Pitfall: For this to work, you need to use an up-to-date version of your Web browser. For 
instance, IE 8 or below will not work. 

 
35. Now use this web browser’s zoom (or view) function to zoom in and increase the size of your 

SVG file on the screen. Continue zooming in as far as your browser will allow. Notice that the 
elements in your SVG file (circles, borders, text) scale up in a way that does not distort their 
quality; there is no pixelation. Again, this is one of the great advantages of vector graphics (non-
rasterized graphics) when compared to bitmap (raster) graphic file formats. 

 
36. In a web browser, go the following URL: 

http://www.w3schools.com/svg/tryit.asp?filename=trysvg_polygon 
(If you are not already familiar with the w3schools website, this is a great place to learn web 
design and web programming languages) 
 

37. The “code” that makes up an SVG image can be written as plain text. This is an interactive page 
that allows you to manipulate the contents of an SVG’s code on the left, then see the output on 
the right using the “See Result” button at the top-right of the text window.  

 
38. Ignore the rest of the left window’s code for now, but notice that there is a tag named “svg.” It 

lists the size of the bounding box (height=“210” width=“500”) then it contains another tag 
named “polygon.”  Use your browser’s “Find in page…” command to find “svg” and “polygon” 
if necessary to ensure you understand the text we are interested in. 
 

39. Notice: The triangle shown is described as a “polygon” drawn between three anchor points. 
These points are listed as x-y coordinates: polygon points=“200,10 250,190 160,210” – there is 
also additional information about the color and outline of the polygon listed as 
style=“fill:lime;stroke:purple;stroke-width:1”.  

 
40. Each of the three sets of coordinates for an anchor point is separated by a space.  For instance, 

“200,10” is the first anchor point, at x=200 and y=10. Change the three anchor points by 
replacing these numbers with new ones. Clicking on the “See Result” button each time.  

 
41. Notice the “style” description. This SVG file uses worded colors rather than numeric values. 

Try entering popular color names, spelled correctly of course. (Since we are just guessing, some 
color names may not work.) For these color fields you may also enter a six character RGB hex 
triplet such as FF0000 (pure red). Hex triplets consist of six character strings where the first two 
characters represent the red value, the second two characters the green value, and the third two 
characters the blue value. Each character must be either between 0-9 or A-F, where 0 is lowest 
and F is highest value (see http://en.wikipedia.org/wiki/Hex_color). These are the same values 
that we edited in step B23. 

 
42. Change the style elements and update the visual display on the right each time using the update 

button. 
 

43. Using a web browser, open the second SVG file you previously created in Inkscape, the one 
containing a single triangle.  

 
44. Zoom out so that you can see the entire triangle with plenty of white space around it (so the 

triangle appears relatively small in the browser window). 
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45. Keeping the triangle SVG open and visible in the web browser, open a simple built-in text 

editor application on your computer. (For example: Notepad, TextEdit.) 
 

46. Using this text editor, open the same SVG file that is simultaneously open in the web browser, 
the one you made containing the single triangle. 

 
47. In the text editor, you should see 30-40 lines of XML format code.  

 
IMPORTANT: This is your second lab report answer to be turned in. 

 
48. In the text editor, locate the portion of this file in the text editor that begins <path d=“ This 

will be followed by the three anchor points of your triangle. It should resemble something like 
<path d=“M 100.42855,415.21934 431.64645, (but with different numbers).  

 
49. Alter one of these three numbers, try to use a new number that is within 100 of the existing 

numbers, at least at first. After you change one of these numbers, in the text editor save this file.  
 

50. Then back in the web browser, reload/refresh the page in the browser (e.g. in Firefox choose 
View > Reload). Notice how you have changed the SVG vector file by simply altering these 
numbers in a text editor. (An SVG image is really just this list of codes and numbers.) 

 
51. Back in the text editor, with the triangle SVG file still open, continue to change the visual 

elements of your SVG file. Note that when changing the polygon anchor points, it is very easy to 
make a triangle no longer a triangle based on where you position your points in space. 

 
52. Change the color of the fill by altering the six character hex triplet that comes after the # using 

the text editor.  For example, if your original file contained fill:#ffff00 you could change this to 
fill:#23acf5 (any six character hex triple containing 0-9 or A-F for each digit). Re-save this SVG 
file after each change and then reload your web browser to view what you changed. 

 
53. Change the opacity of your triangle’s fill using the text editor. For example, if it was fill-

opacity:1 you could change this to fill-opacity:0.25 (opacity ranges from 0 to 1, 0 completely 
transparent and 1 completely opaque). 

 
54. Change the color of the stroke using the text editor. For example if you have stroke:#ff2100 you 

could change this to stroke:#8888aa, and so on. 
 

55. Change the stroke-width using the text editor.  
 

56. In the text editor with your altered SVG XML text displayed, select all of this text and 
copy/paste it into your lab report. 

 
IMPORTANT: This answer is part of your lab report. Also, this file is the fifth file you 
will turn in for this assignment. Please name it with a “5” in the title. 

  
57. Double-check: Before moving on, you should have two SVG files you have created and two text 

responses in your lab report. 
 

You’re done with part B! 
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Part C. Color modes 
 
OVERVIEW: In this section you will toggle between color modes, altering the contents of a raster/bitmap 
image using GIMP. 
 

1. Using a web browser, navigate to the following URL: 
http://www.flickr.com/photos/library_of_congress/sets/72157603671370361/ 

 
2. Using this Library of Congress Flickr project, you will be downloading a single bitmap image 

from the collection ‘1930s-40s in Color’. There are 1,615 color photos in this set, viewable on 23 
different gallery pages (browse from page to page using page numbers at the bottom of any page). 
Choose an image from the specific gallery page that corresponds to the number of your 
birth month plus 10. So if you were born in January, choose an image on page 11 (10 + 1), June 
birthdays choose image on page 16 (6 + 10), and so on.  

 
3. When you have decided on your bitmap image from this collection, download the Medium 500 

JPEG version of your image by doing the following: From the grid of small square images, click 
on your chosen image. This will take you to a page with a larger view. At the top of this page you 
should see an Actions tab. Choose Actions > View all sizes. Also, enter the URL for this 
webpage under Response C3. 

 
4. On the View all sizes page for your image you should see various bitmap files listed by size. 

Click on the link to Medium 500. This will take you to a 500x____ resolution version of this 
bitmap image. Once there right click on the image and choose Save Image As… 

 
5. Save this Medium 500 bitmap file to your local computer. 

 
6. Open the application GIMP. 

 
7. In GIMP, open the JPEG bitmap file you just downloaded from the 1930s-1940s in Color 

collection. 
 

8. Assign the default RGB workspace color profile to this image.  
 

9. Save this file as a PNG file. Choose File > Save As… and select PNG file format in the Save 
dialog. 

 
IMPORTANT: This is the sixth file (RGB color) you will turn in for this assignment. 
Please name it with a “6” in the title. 
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10. In the drop down menu at the top, choose Image > Mode > Grayscale. Notice the image now 
contains no color displayed but only shades of gray. You have converted it to a black and white 
image. 

 
11. Use “Save As…” to save this grayscale version as another new PNG bitmap file to your local 

computer (do not re-save over the color PNG file you created as you will need this later). 
 

IMPORTANT: This is the seventh file (grayscale) you will turn in for your 
assignment. Please name it with a “7” in the title. 

 
12. To revert to the color PNG bitmap file you created, either undo one step (CTRL + Z, or Edit > 

Undo), or you may close the grayscale image and re-open the color PNG file you made. 
 

13. With the color PNG file opened in GIMP, choose Image > Mode > Indexed… 
 

14. An Indexed Color Conversion dialog will appear. Indexed color images specify each specific 
color that they contain in a “colormap.” For your new Colormap select the option Use black and 
white (1-bit) palette and select the Convert button at the bottom right of this window. 

  
15. Notice: You have now converted the original color image to a truly black and white only (not 

grayscale) bitmap image. There are no shades of gray in between because you specified the 
colormap contains only completely black or completely white. This is also called a 1-bit or 
duotone (each pixel is either on or off, a 1 or a 0, hence: 1-bit). 
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16. Save this 1-bit image as another new PNG bitmap file (again do not re-save over the other color 
and grayscale PNG files, you will need them later). 

 
IMPORTANT: This is the eighth file (1-bit) you will turn in for your assignment. 
Please title it with an “8” in the filename. 

 
17. On your local computer, browse to the location where you saved the color, grayscale, and 1-bit 

(duotone) bitmap PNG image files. Look at the file sizes. Notice the large disparity in the 
respective files sizes of these three files, with the color likely twice or more the size of the 
grayscale and the duotone image incredibly small. Consider how this relationship between color 
mode and file size operates. Note the file sizes for each of the three images. 

 
IMPORTANT: This written response needs to be included in your lab report.  Type it 
in now. 

 
18. Either undo back to your color PNG file or reopen the color PNG file.  

 
19. Choose Image > Mode > Index… and this time for your new Colormap select Generate 

optimum palette and for Maximum number of colors enter the value 5 and choose the Convert 
button on the bottom right corner of this window. 

 
20. You have just converted your bitmap image to an image with a 5 color colormap. Notice the 

effect. Save another new PNG bitmap file from this 5 color image. 
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IMPORTANT: This is the ninth file (an image with a 5-color colormap) you will turn 
in for your assignment.  Please name it with a “9” in the filename. 

 
21. Once again, either undo or reopen your full color PNG image.  

 
22. Select Image > Mode > Indexed… and select Use custom palette for your Colormap. Then from 

the small colored box beneath this option, left click on this box to expand a list of color palette 
options. Choose any option you like and then select Convert. Notice the effect on the image. 
(Play with these custom palettes, applying them and undoing, until you find one that you want to 
use for your image). 
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23. Save this custom color palette bitmap image as another new PNG file. 
 

IMPORTANT: This is the tenth file (custom colormap) you will turn in for your 
assignment.  Please name it with a “10” in the filename. 

  
24. Double-check: You should have five image files and two answers completed in your report for 

this section. 
 
 
You’ve finished part C!
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Part D. Your Own Graphic 
 
This last stage of the assignment is open-ended and is intended to allow you to gain further skills with 
vector graphics. Please create an SVG graphic for a purpose of your choice. For instance, you might want 
a graphic to illustrate a flyer for an upcoming event you are hosting, a T-Shirt design for a group you 
belong to, or a logo for your own (perhaps imaginary) consulting company. 
 
REQUIREMENTS:  Your own graphic… 

 must be a SVG file 
 must have a transparent background 
 must contain text (at least one letter) 
 must contain at least one other graphical element 
 and must demonstrate 1 additional Inkscape vector graphics technique that you teach yourself 

using the relevant tutorial. The choices are: 
 

Tutorial Title  
(in Help > Tutorials) 

 
Technique (choose one): 

shapes 3-D composition using snap resize handles on rectangles 

          
advanced editing paths to make a complex path 

           
boolean operations/combining paths to make a complex path 

										 	 	 	 	  
offset/inset/outset paths 

          
tips and tricks irregular gradients (radial or non-linear) 

           
radial tile clones 

          
interpolate interpolate 

           
calligraphy calligraphy (only if you already know something about calligraphy!) 
 

          
 
Your file must demonstrate this technique. E.g., if you choose “editing paths,” you should have a path 
that you edited in the final product.  
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IMPORTANT: The name of the technique you chose is an answer in your lab report.  

  
You are only graded on completion of these very basic content requirements and that the logo is 
submitted in a working SVG file. If it is fun for you to put more effort into this last section go for it, but 
all submissions that meet the basic requirements will receive credit. You are not graded on the aesthetic 
appeal or the extravagance of your graphic. You can receive an “A” on this part of the assignment based 
on the technical requirements alone. 
 

EXTRA CREDIT. Even though you can receive an “A” based on the technical requirements alone, extra 
credit may be awarded for a particularly impressive graphic that showcases skills developed elsewhere in 
this assignment and can be used in the class as an example for students in future years. 

 
Once you complete your own graphic in Inkscape, save it as an SVG file. Keep this file for including in 
your assignment submission. 
 

IMPORTANT: This is the eleventh file you will turn in for this assignment not counting your 
lab report.  

 
Now complete your lab report. After you finish, use the checklist on page 1 to be sure you’ve got 
everything. Then turn in the assignment by uploading it to Canvas with a timestamp before the deadline. 
 

IMPORTANT: Your lab report is the final file you will turn in. 
 

</assignment1> 
 
 
BONUS WORK: 
 
Lab assignment 1 is over, but if you are interested in learning more about vector graphics, or the 
assignment was too easy for you, you can receive extra credit for bonus work.  For this assignment, the 
bonus work will be to teach yourself additional techniques from the Inkscape tutorials or from YouTube 
(or other) videos about Inkscape on the Web.  You can use the list in Part D, or you can find your own 
additional technique on the Web that you would like to learn.  You can decide how to demonstrate you 
have learned the technique. For instance, you might upload an additional file and write a very short 
note about what you did at the end of your lab report. 
 
For this assignment each technique can receive up to +5% extra credit on this assignment, to a maximum 
of +40%. 
 

IMPORTANT: If you are submitting bonus work, be sure you make a note of this on the bottom 
of your lab report so that you receive credit for it. 

 
 
 

kbai. 
 


